Computer specs required for AlbumStomp | StompSoftware

  1. Support
  2. AlbumStomp

Computer specs required for AlbumStomp

On a Mac you need OS X 10.7 or newer, on a PC you need XP or newer.

A closing thought, as with any page layout tool you’ll want a reasonably modern machine with plenty of RAM!

Happy Stomping!!

Related Articles



Still can't find what you're looking for? We're here to help